Über IoBroker an den Messenger SIGNAL (WhatsApp alternative) Nachrichten versenden

  • Hi,


    ich hatte das Ganze dank deiner tollen Anleitung schon einige Monate am laufen. Jetzt habe ich einen Pi auf Bullseye 64bit aktualisiert und komme leider nicht mehr ans Ziel.


    Bei

    Code
    1. sudo -u iobroker signal-cli link -n "iobroker" | tee >(xargs -L 1 qrencode -t utf8)

    Kommt jetzt leider immer folgende Meldung:

    Code
    1. pi@raspberrypi:/usr/local/bin $ sudo -u iobroker signal-cli link -n "iobroker" | tee >(xargs -L 1 qrencode -t utf8)
    2. WARN App - WARNING: Support for new group V2 is disabled, because the required native library dependency is missing: libzkgroup
    3. Missing required native library dependency: libsignal-client

    Hast du eine Idee, wie ich das lösen kann?


    Grüße

    Sebastian

  • nicht getestet. auf eigene Gefahr. k.a. obs funzt und was passiert...

    Alles auf einmal kopieren und dann rechtsklick in putty

    Von hier gesehen..

    https://stackoverflow.com/ques…using-signal-cli-on-linux

  • Hi,

    ich hatte im März Deine Version 0.8.1 für Raspi installiert und registriert, alles lief.

    Nun geht's nicht mehr, beim senden kommt mein

    Code
    1. User +49... is not registered.

    Also dachte ich, registriere ich mal neu. Aber da kommt nach Scannen des QR Codes:

    "Gerät konnte nicht gekoppelt werden

    Ungültge Antwort des Dienstes"


    Ist das jetzt ein Handy App Problem oder liegt es an der signal-cli?

  • Bin begeistert von der Möglichkeit, vom ioBroker auf meinem RasPi2 Signal-Nachrichten an mein Smartphone zu schicken bzw. an den Signal-Windows-Client am PC.
    Nach langer Zeit der Nutzung wollte ich nun zum ersten Mal eine Nachricht vom ioBroker an einen Freund schicken, was nicht funktioniert. Es geht nur die eigene Rufnummer (Notiz an mich, Absender = Empfänger). Ist das so gedacht? Irgendwie steht nirgendwo was dazu, ob man beliebige Empfänger nutzen kann, die man auf dem gekoppelten Smartphone nutzt, oder die Nutzung von signal-cli auf die eigene Nummer beschränkt ist.
    Habe extra eine Nummer eines Freundes auf dem Smartphone verifiziert - brachte keine Änderung.
    Die Fehlermeldung von signal-cli 0.8.1 sieht nach dem Sendeversuch bei mir so aus:

    WARN Manager - Failed to resolve uuids from server, ignoring: java.security.SignatureException: Unexpected signed quote version 4

    Failed to send message: org.whispersystems.signalservice.api.push.exceptions.NotFoundException: Not found

  • Guten Abend in die Runde,


    bei mir lief seit langem die signal-cli ohne Probleme. Seit ca. 26.10. bekomme ich aber keine Nachrichten mehr gesendet. Bei der manuellen Ausführung in der Shell stand was von "not registered". Da ich mit verschiedenen Versuchen nicht erfolgreich war, habe ich eben alle erzeugten Ordner gelöscht und das Ganze nach obiger ANleitung erneut entpackt und verlinkt. Beim Ausführen des "Link" Befehls bekomme ich nun rezidivierend einen Timeout ala:


    "Link request timed out, please try again."


    Hat jemand eine Idee? Bin dankbar für jeden Tipp.