Zigbee richtig Aufbauen mit dem Zigbee Adapter von IoBroker

  • NUR Bei Neuinstallation:


    Was für ein Zigbee Gerät:


    Was auf keinen Fall gemacht werden sollte!!!


    Zigbee Stick mit interner Antenne:


    Nicht einfach in den Raspi oder was auch immer verbinden.

    Immer eine USB Verlängerung benutzen. Am besten eine Aktive.

    Bedeutet, die USB Verlängerung hat ein Verstärker.

    Je länger, um so besser.


    Zigbee Stick mit externer Antenne:

    2 Möglichkeiten:

    Entweder siehe oben. Mit USB Verlängerung.

    oder externe Antenne mit langem Kabel dran.


    Warum das ganze?

    Die Wlan Antenne und die Hardware vom PC stört extrem den Funkverkehr vom Zigbee Coordinator (Zigbeestick)

    Das gilt für alle Zigbee Coordinatoren. Weg von der Hardware, Wlan Antennen.



    Wifi Analyzer --> ogy.de/2vug runterladen für Android und gucken, wo was frei ist. Immer da gucken, wo was frei ist, oder wo sich was überschneidet

    Hier ist zu erkennen das ein Router auf Kanal 1 Läuft. Der nächste auf Kanal 8

    Wenn alles belegt ist, gucken ob man nicht selber den Wlan Router (z.B. Fritzbox) einen anderen Kanal beim 2,4ghz Band gibt. So das was frei wird.

    Im nächsten Bild sucht man jetzt den besten Kanal aus für Zigbee.

    Kanal 1 ist belegt, und dann erst wieder Kanal 8

    Also nehme ich für Zigbee den Kanal 15. Dann sollte dieser Kanal komplett raus sein aus dem wlan 2,4ghz und nichts stört.



    Die kurzen Hügel sind die Zigbee Kanäle. Die großen Hügel die Wlan Kanäle (2,4ghz)

    Wifi Kanal 1 fängt bei Kanal 11 an und hört bei Kanal 14 auf. Also wäre Kanal 15 Perfekt für Zigbee.

    Wifi Kanal 2 (nicht im Bild) würde dann also bei 12 Anfangen und aufhören bei Kanal 15. Also wäre Kanal 16 perfekt für Zigbee.


    Nun kann man im Zigbee Adapter den richtigen Kanal einstellen, oder falls schon ist, den Kanal vom Wlan Router ändern.


    !!!ACHTUNG!!!

    Wer den Kanal ändert wo schon Geräte installiert sind, oder irgendwelche Änderungen macht unter "Einstellung" im Zigbee Adapter, kann riesen Probleme bekommen.

    Man muss alle Geräte neu anlernen.

    Bei falscher Handhabung bekommt man den Zigbee Adapter unter Umständen nicht mehr zum laufen.


    !!!DAHER!!!

    Das gebe ich als TIPP!!!

    BACKUP MACHEN!!!!

    Wer es umbedingt machen möchte bei laufenden Betrieb:

    Alle Geräte deinstallieren. Löschen aus dem Zigbee Adapter. Das keine mehr drin sind.

    Alle Zigbee Geräte Stromlos machen.

    Alle Batteriebetriebene Geräte stromlos machen.

    Das hat was damit zu tun, das die Geräte, bei einem "Fehler" sich nicht von selber wieder anmelden können am Zigbee Stick.

    Neustarten des Raspi's.

    Kontrollieren ob wirklich alle Geräte entfernt wurden.

    Den Zigbee Stick jetzt über den Zigbee Adapter resetten. Soft Reset + (danach) Hardware Reset unter "Einstellung" vom Adapter.

    Jetzt den Kanal ändern im Zigbee Adapter, so das es passt.

    Ist jetzt der Adapter noch grün:

    BACKUP MACHEN!!!

    Jetzt/Danach den Raspi neustarten.

    Gucken(hoffen) das der Zigbee Adapter grün ist/bleibt.

    Alles neu einrichten... Fertig!!!


    Einrichten:

    ERST ganz in der Nähe vom Stick routfähige Geräte installieren.

    Bedeutet, sie laufen mit Dauerstrom. (Steckdosen, Lampen)

    Ganz zum Schluß, auch wenn welche ganz in der Nähe sein sollten, die batteriebetriebenen Geräte installieren.


    Probleme auschließen:


    1. ALLE Geräte in ein USB2 Platz stecken. Egal ob das der Zigbee Stick ist, oder die SSD-Festplatte, oder sonstwas. Wenn noch was in USB3 drin sein sollte, wenn möglich "erstmal" rausziehen. Es darf nichts in USB3 drin sein.


    2. Zigbee Adapter installieren. und wie beschrieben einrichten.


    3. Sollten im Zigbee Adapter Geräte auftauchen, die nicht erkannt werden:

    BACKUP machen. WICHTIG!!!

    Zigbee Adapter als Beta installieren.

    Auf Adapter klicken. Oben "Experte" aktivieren.

    Die Katze oben anklicken und aus "github" den Zigbee Adapter installieren.

    Sollten jetzt immer noch Geräte nicht gefunden werden:

    BACKUP machen. WICHTIG!!!


    In Putty:


    In iobroker einloggen und den Zigbee Adapter starten. Das dauert ein klein Moment, da der Adapter sich selber neu installiert. Im log gucken.


    Nachdem alle Geräte funzen, kann man.. noch nicht lange genug getestet von mir, alles wieder so in USB "verteilen" (USB3 USB2) wie es vorher war.


    Sollten immer noch Probleme auftauchen, dann auf die Standard installation bringen:


    Code
    1. cd /opt/iobroker
    2. iobroker stop
    3. npm remove zigbee-herdsman
    4. npm remove zigbee-herdsman-converters
    5. sudo rm -r /opt/iobroker/node_modules/zigbee-herdsman/
    6. sudo rm -r /opt/iobroker/node_modules/zigbee-herdsman-converters/
    7. sudo rm -r /opt/iobroker/node_modules/iobroker.zigbee/
    8. iobroker start

    In iobroker einloggen und den Zigbee Adapter starten. Das dauert ein klein Moment, da der Adapter sich selber neu installiert. Im log gucken.


    Zigbee Stick vorhanden?

    ls -l /dev/serial/by-id

  • Zigbee Port funzt nicht. USB Resetten ohne Raspi neustart:



    Code
    1. sudo nano usbreset.c

    Das hier dann einfügen:

    Dann weiter in Putty:

    Code
    1. sudo gcc usbreset.c -o usbreset
    2. sudo mv usbreset /usr/local/sbin/

    Adapter muss laufen (Rot/Gelb --> egal)

    Zigbee Adapter in Einstellung gehen.

    Den COM-Anschlussname löschen und den Adapter neu starten. (Darf nichts drin stehen)

    im Log gucken.

    Auf Fehler warten und den Adapter stoppen.


    Jetzt USB Daten anzeigen lassen:

    Code
    1. lsusb

    dort sieht man z.b.:

    Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

    Bus 001 Device 003: ID 0451:16a8 Texas Instruments, Inc. CC2531 ZigBee

    Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub

    also lautet es:

    sudo usbreset /dev/bus/usb/001/003


    Adapter starten. Sollte jetzt wieder laufen