Adapter DrozmotiX/ioBroker.esphome Installation Process exited with code 25

  • Hallo, ich versuche seit längerem den Adapter DrozmotiX/ioBroker.esphome zu installieren und schaff es einfach nicht.

    Die Installation (mit Katze) bricht ab mit Fehlermeldung:

    Building wheel for cryptography (pyproject.toml): finished with status 'error'

    ERROR: Failed building wheel for cryptographyFailed to build cryptographyERROR: Could not build wheels for cryptography, which is required to install pyproject.toml-based projects

    npm WARN optional SKIPPING OPTIONAL DEPENDENCY: osx-temperature-sensor@1.0.8 (node_modules/osx-temperature-sensor):

    npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.3.2: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"arm"})

    npm ERR! code ELIFECYCLE

    npm ERR! errno 1

    npm ERR! Exit status 1npm ERR! npm ERR! Failed at the iobroker.esphome@0.2.4 install script.npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

    npm ERR! A complete log of this run can be found in:npm ERR! /home/iobroker/.npm/_logs/2022-10-19T18_13_10_840Z-debug.log

    host.raspberrypi Cannot install DrozmotiX/ioBroker.esphome#b6adb149202b81607fe1d726bbe7ffa6717d2352: 1

    ERROR: Process exited with code 25

    Meine Daten: Pi4B

    • Node.js: v14.20.1
    • NPM: 6.14.17
    • Datenträgergröße: 28.2 GB
    • Freier Festplattenspeicher: 23.5 GB
    • Aktive Instanzen: 8


  • Hoffe, Du hast vorher ein Backup gemacht. Kann viel passieren, wenn man über github installiert. Auch später...


    Auf eigende Gefahr:


    In iobroker oben auf den "Schlüssel" klicken für Einstellungen.

    Dort bei Repositories auf "beta" stellen/klicken uns speichern.

    Kurz warten und jetzt über "Adapter" ganz normal "esphome" installieren.

    Wenn fertig, kannst Du wieder umstellen auf "stable"

  • Ja genau, hier noch ein auszug aus dem Log:

    error: can't find Rust compiler If you are using an outdated pip version, it is possible a prebuilt wheel is available for this package but pip is not able to install from it. Installing from the wheel would avoid the need for a Rust compiler. To update pip, run: pip install --upgrade pip and then retry package installation. If you did intend to build this package from source, try installing a Rust compiler from your system package manager and ensure it is on the PATH during installation. Alternatively, rustup (available at https://rustup.rs) is the recommended way to download and update the Rust compiler toolchain. This package requires Rust >=1.48.0. [end of output] note: This error originates from a subprocess, and is likely not a problem with pip. ERROR: Failed building wheel for cryptographyERROR: Could not build wheels for cryptography, which is required to install pyproject.toml-based projects

    Failed to build cryptography

    Backup hab ich, danke für den Hinweis

  • Wie gesagt.. nicht über github oder so installieren... das ist super schlecht...

    Kann sein, das schon jetzt was installiert ist im Ordner (opt/iobroker/node_modules)

    Wenn da jetzt was drin sein sollte mit "esphome", muss das gelöscht werden.


    Danach einfach kurz auf beta stellen. einfach unter "Adapter" esphome" suchen und installieren. Danach wieder auf stable stellen