Backup- Reparatur Install Tool ioBroker

  • mach einfach das backup drauf 1Backup15052021.tar.gz

    wenn fertig gib mal ein in putty:

    iobroker status

    iobroker status admin

    Habs heute nochmal versucht - ohne Erfolg. In kürze:


    Code
    1. pi@raspberrypi:~ $ iobroker status
    2. iobroker is running on this host.
    3. Objects type: file
    4. States type: file
    5. pi@raspberrypi:~ $ iobroker status admin
    6. Cannot find any instances of "admin"!




    Und der "admin" adapter bekomme ich nicht neu instaliert.


    Code
    1. pi@raspberrypi:~ $ iobroker install admin
    2. adapter "admin" already installed. Use "upgrade" to upgrade to a newer version.
    3. pi@raspberrypi:~ $ iobroker upgrade admin
    4. Adapter "admin" is up to date.
    5. pi@raspberrypi:~ $ iobroker install admin@4.2.1
    6. adapter "admin" already installed. Use "upgrade" to upgrade to a newer version.
    7. pi@raspberrypi:~ $ iobroker set admin.0 --react false
    8. The instance "admin.0" does not exist!


    ;( > ich schalte jetzt (erstmal) wieder zurück auf die "neu" Installation.


    Gruss, Fidi

  • iobroker start admin

    dann einfach iobroker öffnen

    Hatte ich auch versucht - geht leider nicht:


    Code
    1. pi@raspberrypi:~ $ iobroker start admin
    2. Cannot find any instances of "admin"!

    Keine Instanzen (sichtbar)


    Code
    1. pi@raspberrypi:~ $ iobroker list instances
    2. + instance is alive


    Ich hab glücklicherweise doch eine Backup (Export) meiner meisten Blockly Scrips gemacht/gefunden. Inzwischen konnte ich so die "fehlenden" Objekte schnell ausfindig machen und manuell neu erstellen >> läuft wieder:thumbup:


    Jetzt fehlen mir nur noch ein "paar" im "yahka.0" Adapter erstellte Geräte für HomeKit.


    Ansonsten (abgesehen von verlorenen History Daten) bin ich dann wieder mit meinem System "alive" via "Neuinstallation"


    Danke für deine Unterstützung und Tipps - auch wenn's bei mir nicht funktioniert hatte. Denke Auslösser war entweder der Admin Adapter Update von 4.2.1 zu 5.0.x oder ein zwei "unexpected" power offs als ich was an dar Hauselektrik gemacht hatte und die Sicherung paarmal raus/rein gemacht hatte, :/


    Gruss

    Fidi

  • Moin,


    wie besschrieben jetzt hier im Forum mein Problem mit dem Node-Upgrade auf meinem Raspi. Derzeit ist 12.22.1 installiert. Habe zweimal dein Tool zum Upgraden gestartet. Aber immer bleibe ich bei der 12 Version fest.


    Hier einmal das "Log"/Screen:


  • mein system ist hartnäckig. immer noch 12er version. liegt das nur an der influx db?


  • @Elzershark

    Was kann ich tun? Habe den HAM-Adapter entfernt. Nach Restart von iobroker kam die idenische Fehlermeldung beim Versuch den Zigbee Adapter zu installieren;

    Code
    1. $ ./iobroker add zigbee --host raspberrypi-iob
    2. NPM version: 6.14.12
    3. npm install iobroker.zigbee@1.5.6 --loglevel error --prefix "/opt/iobroker" (System call)
    4. npm ERR! code ENOTSUP
    5. npm ERR! notsup Unsupported engine for homebridge-ewelink@6.7.1: wanted: {"homebridge":"^1.3.3","node":"^14.17.0"} (current: {"node":"12.22.1","npm":"6.14.12"})npm ERR! notsup Not compatible with your version of node/npm: homebridge-ewelink@6.7.1npm ERR! notsup Not compatible with your version of node/npm: homebridge-ewelink@6.7.1npm ERR! notsup Required: {"homebridge":"^1.3.3","node":"^14.17.0"}npm ERR! notsup Actual: {"npm":"6.14.12","node":"12.22.1"}
    6. npm ERR! A complete log of this run can be found in:npm ERR! /home/iobroker/.npm/_logs/2021-06-11T08_56_03_057Z-debug.log
    7. ERROR: host.raspberrypi-iob Cannot install iobroker.zigbee@1.5.6: 1
    8. ERROR: process exited with code 25
  • Hi

    Habe nun meinen iobroker auf 14.18.2 mit deinem tool updated. Alles läuft bis auf den node-red und zwar weil der serialport nicht funkt, obwohl ich den gar nicht verwende. In anderen update anweisungen steht dass dies eigentlich e fast normal ist. Auch eine reparaturanweisung ist dabei. Nur bei mir funkt dies nicht wirklich. Wahrscheinlich weil ich mich in linux gar nicht auskenne.


    Hier ist das thema unter Sonderfälle angeführt:

    https://forum.iobroker.net/top…ig-updaten-2021-edition/2


    Kannst du mir da eine Hilfestellung geben?

    Gebe nun vorab die SD Karte raus und die alte rein, dass der Node-red wieder läuft

    LG Robert



    UPGRADE:

    Der Serial war doch in Globale verwendet - konnte den löschen

    funzt somit

  • Hallo zusammen,

    wie kann ich an der Stelle yes oder no eingeben? Siehe Bild.

    Ich habe keine Ahnung welche Tasten oder Tastenkobination das ist.

    Lachhaft aber ich schaff das nicht. Peinlich aber wahr. :(

    (Boote ich neu startet die piccu nicht die auch installiert ist, wird wohl vorher abgeschaltet in dem Teil geht es wohl darum)

  • Kann man nichts eintragen.

    Manuell machen.

    Code
    1. sudo apt update
    2. sudo apt upgrade

    danach sollte das Tool wieder funzen.

  • Hallo,


    danke erstmal für das Tool. Funktioniert mit dem Raspberry Pi problemlos.


    Es möglich, damit auch eine Sicherung in ein Portainer Image einzuspielen?

    Kann ich Sicherungen, die mit einem Raspberry Pi erstellt habe, auch auf einen X64 Rechner übertragen?