Iobroker update js controller Probleme

  • Hi, ich hoffe mir kann da jemand helfen. Ich habe jetzt mehrmal versucht den js controller zu aktualisieren, auf ne Version größer 2, weil die aktuelle Version vom Alexa Adapter sonst nicht geht. Leider bricht das Update immer mit Fehlern ab und danach kann ich nicht mehr auf den Iobroker zugreifen und muss komplett alles neu aufsetzten, neues Image auf SD Karte, Iobroker neu installieren und Backup einspielen.

    Ich habe es laut Beschreibung so versucht.

    sudo iobroker stop

    sudo iobroker upgrate self

    danach geht nix mehr, auch das Fix nicht und auch ne Iobroker Installation drüberbügeln hilft nicht.

    Vielleicht hat ja jemand einen Rat.

    Ich habe nen Raspberry Pi mit 4 GB und Raspian Duster Lite drauf, installiert mit Elzersharks Tool. Iobroker auch mit Tool installiert.

  • Hi, folgende Ausgabe kommt bei mir im Log

  • Hi, ich glaube ich konnte das Problem lösen. Ich bin vom PI 3 auf den 4 umgezogen und habe das mit der Backup Variante des Tools gemacht. Durch das mitnehmen des Ordners Node Modules wurden dann wohl wieder ältere Versionen auf den PI 4 gespielt und mir fehlten ein paar Module. Ich habe dann jetzt nach dem wiederherstellen des Backup auf dem Pi4 die Iobroker installation noch mal drüberlaufen lassen und jetzt funktioniert alles und ich habe js-controller Version 2.1.1

  • Jau, hattest du ja in einem deiner Videos gesagt. Und ich hatte ja nichts zu verlieren, einfach mal testen. Vorher Backup von SD Karte erstellt, also kein Risiko.

    Noch mal Danke für deine tollen Videos und Anleitungen, die haben mir schon sehr viel geholfen. Auch deine Ideen zu neuen Projekten und ihre Umsetztung finde ich immer Klasse.