Beiträge von Elzershark

    beim Eintragen der Zugangsdaten. Ich habe nur die Zugangsdaten eingegeben. also e-mail + passwort. Sonst keinerlei anderen Einstellungen.

    Ansonsten habe ich die gleiche Version wie Du.

    HAM selber hab ich nichts geändert.

    Zeig mal die konfiguration von HAM Adapter. also in den HAM-Adapte reingehen. Da steht dann ewelink mit bei. wie das aussieht. kannst ja passwort ausblenden/ändern

    https://www.ionos.de/server/vps

    Server kaufen. 1€ im Monat

    Ubuntu installieren

    Im Kontrollcenter:

    ipv6 aktivieren/erstellen

    Firewall Ports freigeben 8081, 8082, u.s.w. Wie gebraucht für iobroker


    Fritzbox:

    Heimnetzübersicht-Netzwerkeinstellungen

    IP-Adressen

    IPv6-Adressen

    DHCPv6-Server im Heimnetz

    DHCPv6-Server in der FRITZ!Box für das Heimnetz aktivieren: anhaken

    DNS-Server, Präfix (IA_PD) und IPv6-Adresse (IA_NA) zuweisen: anhaken


    Fritzbox Portfreigabe für Raspi

    für ipv6 8081(-8335)

    alle Ports die man braucht


    Weiter mit Server:

    sudo apt install 6tunnel

    sudo apt install ufw

    sudo ufw allow 22

    sudo ufw allow 80

    sudo ufw allow 443

    sudo ufw allow 8081

    und alle anderen Ports die man braucht

    sudo ufw enable


    3a02:360:53ed:1300:5221:43ef:4f57:f3ca= raspi IPv6 Adresse


    6tunnel 8081 3a02:360:53ed:1300:5221:43ef:4f57:f3ca 8081

    und alle anderen ports

    1 port = auf was der Server horchen soll 2 port= welcher port angesteuert werden soll vom Raspi


    IPdesServers:8081 ist iobroker


    ps -ef | grep 6tunnel

    kill


    sudo apt install expect

    /opt/iobroker/iobroker-data/files/0_userdata.0/sshlogin.exp


    Adapter

    Shell-Konsole XTerm

    ssh root@ipServer

    mit yes bestätigen..


    exec blockly


    sudo /etc/init.d/networking restart

    nein. war dabei. brauch aber n anderen raspy. der kommt demnächst. dann mach ich weiter. Raspi mit 8GB. aber lieferschwierigkeiten. Dan mach ich weiter.

    Aber, na ja... gibt ja keine Unterstüzung von denen mehr.. hm..

    hallo, ich habe da ein problem, wenn ich dieses board auswähle Board = ESP32 Wrover Module

    kommt Error resolving FQBN: getting


    wenn ich das ai thinker esp32 cam board wähle, kann ich es kompilieren und auch flashen.


    Leider kackt mir das board aber immer wieder ab (habe 3 exemplare, immer das selbe verhalten), der stream läuft, sobald ich gesichtserkennung aktiviere, stottert es und mqtt hat sich einmal verbunden, aber es kommen keine meldungen

    Wenn man es genau so macht wie im Video, kann kein Fehler passieren. wenn alle Geräte heile sind.

    Geht man ein "eigenen Weg, sollte das noch so "gering" sein, wird es nicht funzen.

    Da es spezielle Biblioteken sind, die es so nicht gibt.

    Muss mit 5V betrieben werden. 750mAh sollten es min. sein. Besser mehr. Wlan darf nicht zu weit weg sein.

    Hallo

    Erstmal vielen Dank für das Video. Es ist wirklich sehr gut erklärt und funktioniert bei mir schon mit Zwei Rollos über Broadlink sehr lange. Da ich ein neues Rollo habe, wo es einen Adapter im iobroker gibt, ist es jetzt so das bei dem Adapter motionblinds der Wert bei geschlossenem Rollo 100 % und bei geöffnetem Rollo 0 % ist also genau umgekehrt wie bei dem Script oder Datenpunkt aus dem Video. Besteht die Möglichkeit das man es ändern kann im Datenpunkt damit ich nicht beim Hoch bzw. runterfahren erst überlegen muss welche Prozentzahl ich Alexa sagen muss. Im Wohnzimmer für Rollo hoch 100 % und im Schlafzimmer 0 %

    Danke

    Was passiert, wenn Du diesen Datenpunkt direkt in die iot bringst? Ohne Script?








    Arduino Portable als zip runterladen und entpacken.

    https://www.arduino.cc/en/software

    Rechts "Windows ZIP file"


    Nicht zu sehr verschachtelt entpacken.

    Am besten unter C:

    Dort ist dann der Ordner Arduino. (umgeschrieben)

    Wenn man den öffnet, ist dort sofort die arduino.exe.

    Kann sonst Fehler geben.


    Ordner "portable" erstellen.

    starten.

    Datei->Voreinstellung den Link unten eingeben bei Boardverwaltung URL

    Code
    1. https://arduino.esp8266.com/stable/package_esp8266com_index.json

    Bei Reiter Werkzeuge->Bibiliotheken verwalten klicken

    esp8266 eintippen und installieren.

    Board=lolin(wemos) D1 R2 & mini

    CPU 160 MHZ

    IwIP = V2 higher Bandwidtch


    Diese 4 Bibliotheken...

    PubSubClient

    HX711

    Adafruit_GFX

    Adafruit_ST7735

    unter dem Reiter Sketch->Bibliothek einbinden->Bibliotheken verwalten installieren


    einfach oben in der Suche eingeben. Dann das "beste" installieren. Was quasy kein "schnickschnack" hat.

    z.B. "PubSubClient".

    Da werden einige angezeigt. Einfach das nehmen, was am "einfachsten" aussieht.

    Das wäre z.B. "PubSubClient" by Nick O'Leary. Weil es einfach so "heißt".

    und nicht "MQTTPubSubClient", oder "PubSubClientTools".

    Einfach das "beste/einfachste" installieren. Das funzt zu 90%.


    Den Sketch -->runterladen AlexaWaage.zip<--

    Entpacken und in Arduino - portable - Sketchbook, den Ordner reinkopieren. in diesem Ordner ist die AlexaWaage.ino Datei

    Die öffnen.

    Am besten auf kompilieren klicken (oben links das häcken) . Ob alles i.O. ist und kiene Fehler kommen.

    Klappt das, die Zugansdaten eingeben in der ino Datei


    Code
    1. // Wifi + MQTT settings
    2. #define WIFI_CLIENT_ID "WaageGross"
    3. #define SSID_NAME "elzershark" // SSID network wifi name to connect to
    4. #define SSID_PASSWORD "meinpasswort" // Wifi password
    5. #define MQTT_USER "z.B.Sonoff" // MQTT username
    6. #define MQTT_HOST IPAddress(192, 168, 68, 177) // MQTT broker ip
    7. #define MQTT_PASS "Deinmqttpasswort" // MQTT password
    8. #define MQTT_PORT 1883 // MQTT broker port

    Nun den com port auswählen vom angeschlossenen Wemos und kompilieren.



    Blockly: