Elzershark Administrator

  • Mitglied seit 24. Januar 2019
  • Letzte Aktivität:
Beiträge
521
Erhaltene Likes
76
Punkte
2.996
Profil-Aufrufe
5.180
  • Hallo,

    ich versuche seit kurzem mich ebenfalls mit MQTT und ioBroker. Habe hierzu zwei einfache Fragen.

    Ich bin in der Lage Datenpunkte mittles client.publish von meinem NodeMCU in ioBroker erzeugen zu lassen.

    Diese haben automatisch die Role: 'variable' und als Type:'string'. (PS: kann man das eigentlich beeinflusssen?)


    Die Frage ist was alles muss ich tun um diesen Datenpunkt über Alexa z.B. mit dem Wert '130' zu beschreiben.

    Schätze als erstes den Datenpunkt Type zu 'number' ändern. Aber was stelle ich bei 'Role' ein?

    Und die zweite Frage: wenn ich dann im IoT adapter ein Alexa Gerät hinzufüge und den Datenpunkt ausgewählt habe, was stelle ich hier dann für 'type' ein?

    Danke im Voraus, für Eure Hilfe

    • das kann man hier nicht beantworten. viel testen. string kann bleiben. da das quasy alles ist. true false, nummern..

  • Hallo,

    brauche kurz deine Hilfe, ich brauche wenn es geht das neue Community TR-064 Adapter Blockly Code,

    weil ich habe eins vom dein Video kopiert und installiert, aber es funktioniert nicht er sieht auch ganz anders wie in dein Video, beim Test im Alexa ton kommt raus, aber bei Anruf kein ton also keine Reaktion, und ich bin schritt für schritt wie in der Video durchgegangen.

    Bitte um Rat.

    Mfg. Armento

    • man muss eigentlich nur den echo verknüpfen. sonst nx. die restlichen datenpunkte sollten schon richtig verknüpft sein.

      bei einer ganz normalen standard installation von iobroker und adapter. sollten datenpunkte nicht verknüpft sein, simmt was nicht. mal selber 1x anrufen u.s.w.

      Hab das gerade getestet. funzt einwandfrei

    • Danke für die schnelle Antwort,

      14:30:41.700 warn javascript.o (847) at Object. <anonymous> (script.js.Telefon:24:11)

      das kommt wenn ich mich selber anrufe, beim Test wie schon gesagt kommt die ansage,

      aber wenn ich mich selber anrufe kein Ton.

      Ps. was gebe ich an wenn ich eine neue Skript anlege, es gibt mehrere Angabe wie zb. root-Verzeichnis, root, common, global oder ist egal was ich eintippe?

    • am besten Ordner erstellen. root auswählen. da drin dann die Scripte speichern.sind alle datenpunkte richtig verknüpft?

  • Hallo

    Erstmal vielen Dank für das Tool vom Reparieren des Raspberrys.

    Meine Frage ist welche Dateien werden beim Backup mit gesichert? Auch die HA Bridge? Habe ich, wenn ich eine neue SD Karte für den IoBroker mit der Installationsroutine von dir und hinterher ein Backup der anderen Karte was ich davor gemacht habe alles wieder auf der neuen Karte? Scripte usw.?


    Danke

    • Ich habe leider keine HA Bridge. Das Tool speichert alle Dateien von den beiden Ordner "iobroker-data" und "node_modules" die in /opt/iobroker drin sind. Du kannst es aber leicht Testen. Erstelle ein Backup. Dann lösche etwas von der HA Bridge, was man leicht wieder erstellen kann. Dann das Backup wieder drauf spielen. Wenn das gelöschte wieder vorhanden ist, sollte das also Funktionieren.

      HA-Bridge finde ich so nicht als Adapter. Daher weiß ich es nicht genau.


      Ansonsten, wird alles wieder erstellt, bei Neuinstallationen. Also alle Scripte u.s.w. werden wiederhergestellt.

    • Danke für die schnelle Antwort.

      Ich habe das auch nicht gewusst mit der HA Bridge habe immer gelesen davon aber nie im ioBroker gefunden.

      Ich brauchte es aber für meine Logitech Harmony Companion Fernbedienung um Aktionstasten fremd belegen zu können. Nach ständigem suchen habe ich diese Anleitung gefunden installiert und damit funktioniert es nun.


      https://splittscheid.de/ha-bri…ion-auf-dem-raspberry-pi/

    • Hallo

      Ich nochmal

      Würde die Möglichkeit bestehen das man, die HA Bridge mit in das Backup einbeziehen könnte so das es gesichert und danach wieder installiert wird?

      Die Verzeichnisse sind ja in dem Link enthalten und für dich mit Sicherheit kein Problem das mit zu verarbeiten.

      Das wäre super.

      Danke

  • Saublöde Frage: Was für eine Forumsoftware benutzt du hier auf der Seite?


    ich bin gerade am Neuaufbau meiner Webseite zum Thema 3D Druck und auf der Suche nach einer Forumsoftware.

    Habe bisher simplify benutzt aber irgendwie sagt mir da das Design nicht mehr so zu.


    Danke dir für die Info.


    Gruß

    Andy

  • Hallo

    ich habe Dein iobroker Tool immer für meine Backups vom Raspi 3 genommen und es funktionierte super.

    Jetzt habe ich mir einen Raspi 4 zugelegt und das neue Tool geladen und jetzt kann ich keine Backups mehr machen er speichert nichts mehr unter Programme / Backup . Das alte Tool habe ich gelöscht.

    An was kann das liegen und danke für Deine Bemühungen.


    Reiner

    • Am Tool kanns nicht liegen. Vom Backup her hat sich nichts geändert. Richtige Zugangsdaten? Richtiges Passwort?

  • Hallo, habe das mit der SD Karte und dem Raspberry 4 umgesetzt.Funktioniert auch alles so weit. Hab aber nicht das Auswahlfenster mit der Frage ob ich mit oder ohne SD Karte arbeiten möchte. Jetzt meine Frage, gibt es eine Möglichkeit dies wieder rückgängig zu machen ?


    Gruß

    Wendelin

  • Jetzt schreibe ich doch hier:

    mit Linux mint 19.2 funktioniert das tool leider noch nicht oder ich mach was falsch.
    Beim reparieren kommt:


    sudo: Kein TTY vorhanden und kein »askpass«-Programm angegeben

    in CMD


    kann garnichts damit anfangen.

    vl auch was kleines?

    Freundliches Grüße

    • Funzt nur, wenn Du im Toll die Zugangsdate von Root eingibst. Oder der Benutzer muss Root Rechte haben. Nach googlen wie man einen Root Benutzer erstellt..

  • Bekomme gerade im IOBroker Forum Support

    • Beim Proxy einstellen.. Nicht das W-Lan auswählen. Das so lassen wie es ist. Schon etwas lange her. In der Adapter Beschreibung vom ioBroker. Beim Fragezeichen beim Tuya Adapter. In der Seite auf "Proxy-Page" klicken....... so machen wie ich das da mit Bildern versehen habe. Unter Android.... Die letzten Bilder die so "Schwarz" sind...

  • meine IP ist 192.168.178.xx

  • eben nicht da geht nichts auf

  • Hallo

    wenn ich ioBroker neu installiere in Ubuntu auf win 10 kommt zum Schluß nicht ( Open http://localhost:8081 in a browser and start configuring )

    sondern Open http://169.254.184.xxx die letzten drei Zahlen habe ich mit x dargestellt.


    Grüße

    • Jo. Deine ioBroker IP ist das dann halt... Im Browser eingeben und Zack.. ioBroker geht auf

  • danke , wenn ich beim Backup im WinSCP alles ausfülle bleibt das Kennwort nicht gespeichert und als Rechnername muss ich doch die ip vom Pi ( Win) nehmen.Danke für Deine Bemühungen.

    Grüße

    • Auf Bearbeiten klicken. Dann deine Daten eingeben und auf Speichern klicken. Dann bleibt alles gespeichert

    • Hallo

      es mache ich ja aber es bleibt nicht gespeichert das Passwort alles andere bleibt gespeichert.

      Grüße

    • Das Problem kenne ich nicht. Das Programm wird wahrscheinlich nicht gespeichert, wenn man kein Admin ist auf seinem PC. Wie macht sich das bemerkbar, das es nicht gespeichert wird? Kommst Du gar nicht auf dein Raspi?

  • Hallo

    wie kann ich Ubuntu wieder deinstallieren.Ich möchte nochmal von ganz vorne beginnen.


    Grüße

  • Hallo

    wenn ich alles genau so mache wie im Video kann ich jedesmal das Passwort nicht eingeben es wird einfach nicht genommen.Was mache ich falsch.Danke für Deine Bemühungen.

    Grüße

  • Hallo

    da ist überall nur die Start Datei und nicht die Start.bat Datei drin.Der zweite Link geht nicht und die Datei ist nicht die Backup Raspi3.zip.Bei mir funktioniert es nicht wenn ich es mache es sind bei dem Tool andere Sachen drin als Du in Deinem Video beschreibst.


    Grüße

    • hi, ich weiß leider nicht welches Video Du meinst. Mir fällt nicht ein was Raspi3.zip sein soll. Die "start" Datei, ist die start.bat. Das wird bei dir wahrscheinlich nicht angezeigt, da Du nicht die Dateierweiterung im Windows aktiviert hast.

      Es gibt ein neues Video von dem Tool:

      Das gibt es hier: Backup- Install Tool ioBroker

  • Hallo

    ich verfolge schon länger Deine Beiträge und die sind gut gemacht man kommt als Anfänger gut mit.Ich finde aber den Ordner zum downloaden Backup Raspi3.zip nicht kannst Du mir den mal schicken .Danke für Deine Bemühungen.

    Grüße